Стало медленное NFS

Разбор непоняток

Стало медленное NFS

Postby Myriogon » 29 Jan 2016, 13:14

У меня был компьютер с WinXP и запущенным на нём Hanewin NFS. Мой Asus HDP-R3 монтировал шару с него и скорость по мнению dd была порядка 9.5 Мегабайт в секунду.

К сожалению по множеству причин (смена винтов на 3 ТБ и другим) мне пришлось менять ОС на сервере на Win8.1. С теми же шарами запущен Hanewin NFS (строка в exports: E:\Video -name:Video -readonly -range 192.168.0.1 192.168.0.255). Но скорость теперь при чтении - жалкие 600 Килобайт в секунду.
В плеере ничего не менялось, модуль mounts со всеми прежними конфигами (в частности параметры такие /tmp/nfs/mnt/Video 192.168.0.100:/Video nfs nolock,ro). В проводах, роутере токже всё неизменно. Аппаратура сервера прежняя. А скорость - просела в 15 раз.
Code: Select all
~ # dd if=/tmp/nfs/mnt/Video/tests/Jellyfish-45-Mbps.mkv of=/dev/null
659536+1 records in
659536+1 records out
337682887 bytes (322.0MB) copied, 544.010474 seconds, 606.2KB/s

При этом, умудрившись примонтироваться из большого компьютера под Win7 к NFS-шаре, я получил скорость 35 Мегабайт в секунду. Т.е. сам комп-сервер и NFS-сервер на нём способны к таким весьма нормальным скоростям, не просаживаясь при этом ни по процессору, ни по памяти.

Вот настройки haneWIN NFS | +
haneWIN_NFS__Server.png
Настройки haneWIN NFS. Вкладка: Server
haneWIN_NFS__Server.png (8.89 KiB) Viewed 1643 times

haneWIN_NFS__NFS.png
Настройки haneWIN NFS. Вкладка: NFS
haneWIN_NFS__NFS.png (12.24 KiB) Viewed 1643 times


Подскажите, пожалуйста, что такое здесь может быть не так?
Asus O!Play HDP-R3. AMP R12.5. VRT 6.12; Сеть: кабель, DLink Dir-655;
Asus O!Play HDP-R1. AMP R12.5. VRT 6.12
Myriogon
 
Posts: 30
Joined: 08 Nov 2010, 11:30

Re: Стало медленное NFS

Postby Virtual » 29 Jan 2016, 13:49

у тя в подписи 2 плеера...
один из них переведи в nogui, подцепи винт по sata с ФС ext* в мосе включи nfs сервер и другим плеером подключи шару и посмотри-сравни
| +
будет примерно так
dd of=/dev/null if=/tmp/nfs/mnt/216.sda3/disk_mars.bin bs=8192
536870912 bytes (512.0MB) copied, 45.059881 seconds, 11.4MB/s

на вопрос
то такое здесь может быть не так?
ответиш сам.
марсы: HDS7 (смотрелка AMP скин vrt уже без вариантов)
HDR12 AMP (обычно сервер с RAM 256 и возможностью подключить 2 SATA диска 2T+)
XTR PRO(AMP, HTTP(S) NFS SMB FTP сервер +trans2.84 + 2 SATA диска 2T+
сатурны: XTR Prodigy, R6S(512Mb_NAND), HD900A(_MD*) прошивка
User avatar
Virtual
 
Posts: 6203
Joined: 01 Oct 2010, 17:17
Location: UFA RU

Re: Стало медленное NFS

Postby Myriogon » 29 Jan 2016, 13:59

Ну да, в подписи-то два. Но второй у родителей. Далеко. По нему тоже как-то были вопросы, поэтому в подписи он присутствует.
Asus O!Play HDP-R3. AMP R12.5. VRT 6.12; Сеть: кабель, DLink Dir-655;
Asus O!Play HDP-R1. AMP R12.5. VRT 6.12
Myriogon
 
Posts: 30
Joined: 08 Nov 2010, 11:30

Re: Стало медленное NFS

Postby Virtual » 29 Jan 2016, 14:28

ну что могу сказать, хочеш нормальный сервак NFS и не только поищи еще плеерок на 1хх3 1186 чипе.
ну или воюй с доп параметрами монтирования nfs (о этом на форуме ведро инфы. не ты первый), как минимум обрати внимание на параметры
udp вс tcp
nolock вс lock
...
марсы: HDS7 (смотрелка AMP скин vrt уже без вариантов)
HDR12 AMP (обычно сервер с RAM 256 и возможностью подключить 2 SATA диска 2T+)
XTR PRO(AMP, HTTP(S) NFS SMB FTP сервер +trans2.84 + 2 SATA диска 2T+
сатурны: XTR Prodigy, R6S(512Mb_NAND), HD900A(_MD*) прошивка
User avatar
Virtual
 
Posts: 6203
Joined: 01 Oct 2010, 17:17
Location: UFA RU

Re: Стало медленное NFS

Postby Myriogon » 29 Jan 2016, 14:35

О, я понял идею. Проверил на другой машине с Win7. Там возвёл сервер тот же самый, подмонтировался Асусом. И получил скорость 10 Мб/с. Т.е. дело каким-то образом связано с Win8. Win8 такая ужасная? И ничего с этим не сделать? Или ты намекал что "не так" здесь Windows-ы? :-)
Asus O!Play HDP-R3. AMP R12.5. VRT 6.12; Сеть: кабель, DLink Dir-655;
Asus O!Play HDP-R1. AMP R12.5. VRT 6.12
Myriogon
 
Posts: 30
Joined: 08 Nov 2010, 11:30

Re: Стало медленное NFS

Postby Myriogon » 01 Feb 2016, 12:56

Я решил. Помогло tcp

Сначала установил на серверную машину Win7 - это не помогло, хотя я и надеялся на это :-)

Стал пробовать разное по совету:
Virtual wrote:воюй с доп параметрами монтирования nfs...
udp вс tcp
nolock вс lock

lock в моём случае сделал только более медленным само монтирование (секунд 15 ждать приходится). А помогло именно tcp. Сейчас у меня в параметрах nolock,ro,tcp вместо ранее прекрасно работавшего nolock,ro
Скорость сейчас 8.1 Мб/с, что более чем в 10 раз превышает результат по умолчанию (хотя и не 10 Мб/с, как с другого Win7-компьютера), так что FullHD 50-60 Мбит/с-фильмы должен тянуть. Получается, что udp, хотя, как на первый взгляд кажется, и должен быть быстрее, в данном случае где-то очень сильно затыкается.

Virtual, спасибо!
Asus O!Play HDP-R3. AMP R12.5. VRT 6.12; Сеть: кабель, DLink Dir-655;
Asus O!Play HDP-R1. AMP R12.5. VRT 6.12
Myriogon
 
Posts: 30
Joined: 08 Nov 2010, 11:30

Re: Стало медленное NFS

Postby Virtual » 01 Feb 2016, 14:12

в данном случае где-то очень сильно затыкается.

:mrgreen: ну вы догадались наверное где...
| +
плеер сервер:100мбит сеть, 400МГц тактовая проца,3-10ВА энергопакет,протокол udp :11.4MB/s 8-)
марсы: HDS7 (смотрелка AMP скин vrt уже без вариантов)
HDR12 AMP (обычно сервер с RAM 256 и возможностью подключить 2 SATA диска 2T+)
XTR PRO(AMP, HTTP(S) NFS SMB FTP сервер +trans2.84 + 2 SATA диска 2T+
сатурны: XTR Prodigy, R6S(512Mb_NAND), HD900A(_MD*) прошивка
User avatar
Virtual
 
Posts: 6203
Joined: 01 Oct 2010, 17:17
Location: UFA RU

Re: Стало медленное NFS

Postby Myriogon » 01 Feb 2016, 15:40

Не, не догадываюсь. Намёк под спойлером прочитал, но не догадался всё равно :) Винда плохая?
Asus O!Play HDP-R3. AMP R12.5. VRT 6.12; Сеть: кабель, DLink Dir-655;
Asus O!Play HDP-R1. AMP R12.5. VRT 6.12
Myriogon
 
Posts: 30
Joined: 08 Nov 2010, 11:30


Return to Что-то не так

Who is online

Users browsing this forum: No registered users and 3 guests