RssEx 2.0.7 не работают Rutube и Ivi

Разбор непоняток

RssEx 2.0.7 не работают Rutube и Ivi

Postby snisni » 11 May 2011, 17:51

Добрый день.
Поставил штатно через MoServices manager RssEx 2.0.7 final, все практически работает более-менее, в т.ч. YouTube, а вот Rutube и Ivi.ru не хотят, пишет что "Cannot play this media" или как-то так. Прошивка R1 1.35 оригинальная. Стоит патч awk. Интересно то, что примерно в феврале ставил какую-то версию RssEx (2.0.2 вроде) с сайта разработчиков (http://code.google.com/p/media-translate/ ) ставил дополнительные утилиты как там рекомендовалось (rtmpdump, xsltproc и т.п.), прописывал в настроечный файл translate.conf ссылки на них и все сервисы работали. Здесь же посмотрел - уже все стоит как надо, по идее все должно работать, попробовал менять эти файлы на более ранние версии, менять плагины и т.п., ничего не помогает...
Может у кого-то что-то подобное было?
snisni
 
Posts: 12
Joined: 11 May 2011, 17:36

Re: RssEx 2.0.7 не работают Rutube и Ivi

Postby FarVoice » 11 May 2011, 18:32

сайты не стоят на месте. Видимо, что-то поменяли и парсеры не работают. Надо копать...
ASUS O!Play R1 (amp_r12_vrtn), xTreamer Pro (amp_r12_vrt), xTreamer Prodigy (iNeXT 2.14 r2), IconBIT HDR12L (amp_r12_vrt), 3Q F425HW (xds42gl_7725_r3), MyGica A11 (mygica_m3_20121222)
User avatar
FarVoice
Администратор
 
Posts: 8573
Joined: 03 Sep 2010, 01:27
Location: Russia, Moscow

Re: RssEx 2.0.7 не работают Rutube и Ivi

Postby nnb » 11 May 2011, 20:48

про IVI:
viewtopic.php?p=10872#p10872

c RuTube просто правка плагина не помогла. похоже на то, что нужно пересобирать rtmpdump.
посоветовали использовать патч http://tradiz.org/files/rtmpdump-2.3-r5 ... _vod.patch

плагин для Zoomby.ru тоже нужно править. хотя клипы с zoomby.ru/music/ пока показывает. хотя на сайте что-то поменялось и надо править скрипты интерфейса.
Last edited by nnb on 12 May 2011, 22:07, edited 1 time in total.
nnb
 
Posts: 125
Joined: 21 Feb 2011, 20:32

Re: RssEx 2.0.7 не работают Rutube и Ivi

Postby snisni » 12 May 2011, 00:49

Суть проблемы понял, спасибо.



IVI заработал после этого исправления! Только, что интересно, бывает что не с первого раза фильм запускается, один раз тыкнешь - та же ошибка, а со второго или третьего раза проходит. Хотя вроде так и раньше бывало, когда он ранее работал.

nnb wrote:c RuTube просто правка плагина не помогла. похоже на то, что нужно пересобирать rtmpdump.
посоветовали использовать патч http://tradiz.org/files/rtmpdump-2.3-r5 ... _vod.patch


Да, а что с этим патчем делать? Я так понял надо его куда-то пихнуть, и затем перекомпилировать rtmpdump? Ну это непросто (для меня) :) Легче подождать обновленную версию rtmpdump...
Да, а просто с выложенным плагином для RuTube действительно не работает...
Спасибо в любом случае!
Вообщем похоже надо ждать RssEx 2.0.8 с учетом новых веяний...
snisni
 
Posts: 12
Joined: 11 May 2011, 17:36

Re: RssEx 2.0.7 не работают Rutube и Ivi

Postby FarVoice » 12 May 2011, 09:17

насчёт RssEx 2.0.8 - видимо timduck либо что-то замышляет глобально другое, либо просто забросил пакет, либо у него банально не хватает времени. Даже плагины не обновлялись с 12 марта :( http://code.google.com/p/media-translate/
ASUS O!Play R1 (amp_r12_vrtn), xTreamer Pro (amp_r12_vrt), xTreamer Prodigy (iNeXT 2.14 r2), IconBIT HDR12L (amp_r12_vrt), 3Q F425HW (xds42gl_7725_r3), MyGica A11 (mygica_m3_20121222)
User avatar
FarVoice
Администратор
 
Posts: 8573
Joined: 03 Sep 2010, 01:27
Location: Russia, Moscow

Re: RssEx 2.0.7 не работают Rutube и Ivi

Postby nnb » 12 May 2011, 10:10

плагины не обновлялись, т.к. до конца апреля в этом не было необходимости.
я могу внести изменения в svn RSS Ex, а вот выложить в Downloads уже не могу.
да пока и выкладывать особо нечего.

c RuTube я пока не разобрался. вроде подобрал параметры запуска rtmpdump, но все одно что-то не хочет работать при запуске из translate.cgi
при запуске rtmpdump c этими параметрами руками - поток отдается. эксперименты продолжаются.

в плагине для Zoomby я начал делать правки. но там еще и awk-скрипт править надо. а awk я практически не знаю, так что ковыряюсь.
nnb
 
Posts: 125
Joined: 21 Feb 2011, 20:32

Re: RssEx 2.0.7 не работают Rutube и Ivi

Postby nnb » 12 May 2011, 21:57

продолжил эксперименты с RuTube.
нашел свои ошибки, что наделал внося правки в rutube.ru.plg. исправил. см. вложение.

после этого еще какая-то часть роликов с RuTube стало можно посмотреть на плеере.
но все же видимо нужно перекомпилить rtmpdump. причин для этого несколько. а вот решение пока подсказали только для одной проблемки. :(
Attachments
rutube.ru.plg.zip
плагин для RuTube
(1.6 KiB) Downloaded 285 times
nnb
 
Posts: 125
Joined: 21 Feb 2011, 20:32

Re: RssEx 2.0.7 не работают Rutube и Ivi

Postby FarVoice » 12 May 2011, 22:35

Добавил эти исправления в модуль. Кому надо - обновите!
ASUS O!Play R1 (amp_r12_vrtn), xTreamer Pro (amp_r12_vrt), xTreamer Prodigy (iNeXT 2.14 r2), IconBIT HDR12L (amp_r12_vrt), 3Q F425HW (xds42gl_7725_r3), MyGica A11 (mygica_m3_20121222)
User avatar
FarVoice
Администратор
 
Posts: 8573
Joined: 03 Sep 2010, 01:27
Location: Russia, Moscow

Re: RssEx 2.0.7 не работают Rutube и Ivi

Postby spirt.no.off » 13 May 2011, 01:00

nnb wrote:продолжил эксперименты с RuTube.
нашел свои ошибки, что наделал внося правки в rutube.ru.plg. исправил. см. вложение.

после этого еще какая-то часть роликов с RuTube стало можно посмотреть на плеере.
но все же видимо нужно перекомпилить rtmpdump. причин для этого несколько. а вот решение пока подсказали только для одной проблемки. :(

Добавил в прошивку IconBit - запускается всё, но на 10-15 сек и зависон, реагирует только на стоп
spirt.no.off
 
Posts: 28
Joined: 10 Apr 2011, 21:24

Re: RssEx 2.0.7 не работают Rutube и Ivi

Postby snisni » 13 May 2011, 01:25

spirt.no.off wrote:Добавил в прошивку IconBit - запускается всё, но на 10-15 сек и зависон, реагирует только на стоп

Аналогично
snisni
 
Posts: 12
Joined: 11 May 2011, 17:36

Next

Return to Что-то не так

Who is online

Users browsing this forum: No registered users and 2 guests